User Tools

Site Tools


Editing actions

Editing schematics or symbols in gschem is carried out by using editing actions in the main window. There are four ways to trigger an editing action: through one or more keystrokes using the keyboard; via the main menu or toolbar; or via context menus.

Many editing actions operate on the current selection. See Selecting objects.

If you don't like the result of a using an editing action, you can undo it by pressing Ctrl+Z or using Edit→Undo. To restore the results of an action after an undo, press Ctrl+Y or use Edit→Redo.


All editing actions have a keybinding associated with them. A keybinding is triggered by pressing a series of key combinations on the keyboard. For example, the gEDA documentation can be displayed using the keybinding HM: type the H key, followed by the M key.

Sometimes, keybindings include modifier keys. For example, to begin inserting a “bus” into the schematic, the keybinding is Shift+B: type the B key while holding down one of the keyboard's Shift keys.

If you type a key combination, it will be briefly displayed in the status bar, unless it forms the start of a multi-stroke keybinding, in which case it will be displayed in the status bar until you press another key. For example, if you press H, the letter “H” will appear in the status bar. If you then press M to display the manual, the status bar will briefly show “H M” and then go blank.

The “Hotkeys” window (accessible using Help→Hotkeys) displays all of the current keybindings and the actions they are bound to. The keybindings can easily be altered using the configuration files. For more information, see Configuring gschem.

The main menu and toolbars

To use the main menu or toolbars to activate an action, simply click on them with the left mouse button. Note that if you hover the mouse pointer over one of the toolbar buttons, more information on the action will be displayed in a tooltip.

Each entry in the main menu shows the equivalent keybinding. This is a good way of learning which keys to press to do particular actions without using the “Hotkeys” window.

Context menus

If you click in the schematic view area of the main window with the right mouse button, a context menu will pop up. This menu contains a few commonly-used editing actions.

geda/gschem_ug/editing_actions.txt · Last modified: 2014/04/24 01:35 by vzh