User Tools

Site Tools


Mouse gesture support

Some actions can be accessed using mouse gestures. Mouse gestures are performed by clicking and dragging the middle mouse button. Gestures are not normally enabled; to enable them, you need to add:

(middle-button "stroke")

to a gschem configuration file.

By default, the following gestures are available:

  • Draw a “Z” to begin drawing a region of interest box to zoom to, like View→Zoom Box (see Viewing schematics).
  • Draw a line upwards to zoom out.
  • Draw a line downwards to zoom in.
  • Draw a “S” to return to Select Mode (see Selecting objects).
  • Draw a “C” to copy selected objects, like Edit→Copy Mode (see Moving and copying).
  • Draw a “M” to move selected objects, like Edit→Move Mode (see Moving and copying).
  • Draw an “E” to edit selected objects, like Edit→Edit.
  • Draw a “D” to delete selected objects, like Edit→Delete.
  • Draw an “L” to begin adding lines.
  • Draw an “N” to begin adding nets.

To modify or add to the available gestures, please see examples in the gschem system configuration file.

geda/gschem_ug/stroke.txt · Last modified: 2012/02/20 15:14 (external edit)